Problems with Lync 2010 client and Trio Callcenter interaction.

I’ve recently had a strange problem which I thought would be nice to share.

The environment is Lync 2010 Standard edition and Trio Enterprise 3.2 from Enghouse Interactive. The Lync Client is used as phone app for Trio inbound and outbound calls. When a Call comes in to the contact center, the Lync Client should automatically answer the call when the agent picks it up. Likewise, when an outbound call is made, the Lync Client should automatically pick up the outbound call from Trio Agent and route it to the PSTN Gateway.

In my case, the inbound call seemed to be working fine, but outbound calls would sometimes make the Trio agent go in to a lock. The Trio agent would also make a callback to the Lync Client, resulting in a missed call from the very same number as the Trio agent uses for outbound call. This happened all the time.
Also, the employees at the callcenter complained about poor audio quality in their headsets and the Lync klient said “Your computer is causing poor audio quality”. This set me off in a direction where I started thinking maybe there was something wrong with the headsets.The headsets are Jabra Pro 9465 Duo, and there you go 🙂

I checked the firmware on the headsets in use, and discovered it was quite old. Installed the Jabra PC Suite and ran Firmware Updater. The new firmware was 3.8.2(the old one was 3.1.5 if I remember correctly) from Sept 2012. After the firmware update, everything is working fine.

Advertisements

One thought on “Problems with Lync 2010 client and Trio Callcenter interaction.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s